using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"vn (-?[0-9. ]+){3}|v (-?[0-9. ]+){3}|f ([0-9. \/]+){3}";
string input = @"v -1 1 0
v -1 0 0
v 1 0 0
v 1 1 0
v 0 2 0
f 1 2 3 4 5
vn 0 0 1
vn 0.707 0 -0.707
vn 1 2 3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}