const regex = /vn (-?[0-9. ]+){3}|v (-?[0-9. ]+){3}|f ([0-9. \/]+){3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('vn (-?[0-9. ]+){3}|v (-?[0-9. ]+){3}|f ([0-9. \\\/]+){3}', 'gm')
const str = `v -1 1 0
v -1 0 0
v 1 0 0
v 1 1 0
v 0 2 0
f 1 2 3 4 5
vn 0 0 1
vn 0.707 0 -0.707
vn 1 2 3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}