// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)vn (-?[0-9. ]+){3}|v (-?[0-9. ]+){3}|f ([0-9. \/]+){3}").unwrap();
let string = "v -1 1 0
v -1 0 0
v 1 0 0
v 1 1 0
v 0 2 0
f 1 2 3 4 5
vn 0 0 1
vn 0.707 0 -0.707
vn 1 2 3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}