re = /vn (-?[0-9. ]+){3}|v (-?[0-9. ]+){3}|f ([0-9. \/]+){3}/m
str = 'v -1 1 0
v -1 0 0
v 1 0 0
v 1 1 0
v 0 2 0
f 1 2 3 4 5
vn 0 0 1
vn 0.707 0 -0.707
vn 1 2 3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end