import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "vn (-?[0-9. ]+){3}|v (-?[0-9. ]+){3}|f ([0-9. \\/]+){3}";
final String string = "v -1 1 0\n"
+ "v -1 0 0\n"
+ "v 1 0 0\n"
+ "v 1 1 0\n"
+ "v 0 2 0\n\n"
+ "f 1 2 3 4 5\n\n"
+ "vn 0 0 1\n"
+ "vn 0.707 0 -0.707\n"
+ "vn 1 2 3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}