#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)^\.[^(\s|\.)].*$"
Local $sString = ".Caution vs. Warning" & @CRLF & _
"[#caution-vs-warning]" & @CRLF & _
"" & @CRLF & _
". ghfghgh" & @CRLF & _
".. ghghghgf" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
".Admonition paragraph syntax" & @CRLF & _
"[source]" & @CRLF & _
"----" & @CRLF & _
"WARNING: Wolpertingers are known to nest in server racks. <1> <2>" & @CRLF & _
"Enter at your own risk." & @CRLF & _
"----" & @CRLF & _
"<1> The label must be uppercase and immediately followed by a colon (`:`)." & @CRLF & _
"<2> Separate the first line of the paragraph from the label by a single space." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")