package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?m)^\.[^(\s|\.)].*$`)
var str = `.Caution vs. Warning
[#caution-vs-warning]
. ghfghgh
.. ghghghgf
.Admonition paragraph syntax
[source]
----
WARNING: Wolpertingers are known to nest in server racks. <1> <2>
Enter at your own risk.
----
<1> The label must be uppercase and immediately followed by a colon (\`:\`).
<2> Separate the first line of the paragraph from the label by a single space.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}