# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)^\.[^(\s|\.)].*$"
test_str = (".Caution vs. Warning\n"
"[#caution-vs-warning]\n\n"
". ghfghgh\n"
".. ghghghgf\n\n\n"
".Admonition paragraph syntax\n"
"[source]\n"
"----\n"
"WARNING: Wolpertingers are known to nest in server racks. <1> <2>\n"
"Enter at your own risk.\n"
"----\n"
"<1> The label must be uppercase and immediately followed by a colon (`:`).\n"
"<2> Separate the first line of the paragraph from the label by a single space.\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.