// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?m)^\.[^(\s|\.)].*$").unwrap();
let string = ".Caution vs. Warning
[#caution-vs-warning]
. ghfghgh
.. ghghghgf
.Admonition paragraph syntax
[source]
----
WARNING: Wolpertingers are known to nest in server racks. <1> <2>
Enter at your own risk.
----
<1> The label must be uppercase and immediately followed by a colon (`:`).
<2> Separate the first line of the paragraph from the label by a single space.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}