$re = '/(?m)^\.[^(\s|\.)].*$/m';
$str = '.Caution vs. Warning
[#caution-vs-warning]
. ghfghgh
.. ghghghgf
.Admonition paragraph syntax
[source]
----
WARNING: Wolpertingers are known to nest in server racks. <1> <2>
Enter at your own risk.
----
<1> The label must be uppercase and immediately followed by a colon (`:`).
<2> Separate the first line of the paragraph from the label by a single space.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);