use strict;
my $str = '.Caution vs. Warning
[#caution-vs-warning]
. ghfghgh
.. ghghghgf
.Admonition paragraph syntax
[source]
----
WARNING: Wolpertingers are known to nest in server racks. <1> <2>
Enter at your own risk.
----
<1> The label must be uppercase and immediately followed by a colon (`:`).
<2> Separate the first line of the paragraph from the label by a single space.
';
my $regex = qr/(?m)^\.[^(\s|\.)].*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}