#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([$%])[A-Z][a-z]{2,}(?1): \[(?<fisrst>\d+)\]\|\[(?<second>\d+)\]\|\[(?<third>\d+)\]\|$"
Local $sString = "$Request$: [73]|[115]|[105]|" & @CRLF & _
"%Taggy$: [73]|[73]|[73]|" & @CRLF & _
"%Taggy%: [118]|[97]|[108]|" & @CRLF & _
"$Request$: [73]|[115]|[105]|[32]|[75]|" & @CRLF & _
"This shouldnt be valid%Taggy%: [118]|[97]|[108]|" & @CRLF & _
"$tAGged$: [97][97][97]|" & @CRLF & _
"$Request$: [73]|[115]|[105]|true" & @CRLF & _
""
Local $sSubst = "$2 $3 $4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)