// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([$%])[A-Z][a-z]{2,}(?1): \[(?<fisrst>\d+)\]\|\[(?<second>\d+)\]\|\[(?<third>\d+)\]\|$").unwrap();
let string = "$Request$: [73]|[115]|[105]|
%Taggy$: [73]|[73]|[73]|
%Taggy%: [118]|[97]|[108]|
$Request$: [73]|[115]|[105]|[32]|[75]|
This shouldnt be valid%Taggy%: [118]|[97]|[108]|
$tAGged$: [97][97][97]|
$Request$: [73]|[115]|[105]|true
";
let substitution = "$2 $3 $4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}