import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([$%])[A-Z][a-z]{2,}(?1): \\[(?<fisrst>\\d+)\\]\\|\\[(?<second>\\d+)\\]\\|\\[(?<third>\\d+)\\]\\|$";
final String string = "$Request$: [73]|[115]|[105]|\n"
+ "%Taggy$: [73]|[73]|[73]|\n"
+ "%Taggy%: [118]|[97]|[108]|\n"
+ "$Request$: [73]|[115]|[105]|[32]|[75]|\n"
+ "This shouldnt be valid%Taggy%: [118]|[97]|[108]|\n"
+ "$tAGged$: [97][97][97]|\n"
+ "$Request$: [73]|[115]|[105]|true\n";
final String subst = "$2 $3 $4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}