$re = '/^([$%])[A-Z][a-z]{2,}(?1): \[(?<fisrst>\d+)\]\|\[(?<second>\d+)\]\|\[(?<third>\d+)\]\|$/m';
$str = '$Request$: [73]|[115]|[105]|
%Taggy$: [73]|[73]|[73]|
%Taggy%: [118]|[97]|[108]|
$Request$: [73]|[115]|[105]|[32]|[75]|
This shouldnt be valid%Taggy%: [118]|[97]|[108]|
$tAGged$: [97][97][97]|
$Request$: [73]|[115]|[105]|true
';
$subst = "$2 $3 $4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;