# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([$%])[A-Z][a-z]{2,}(?1): \[(?<fisrst>\d+)\]\|\[(?<second>\d+)\]\|\[(?<third>\d+)\]\|$"
test_str = ("$Request$: [73]|[115]|[105]|\n"
"%Taggy$: [73]|[73]|[73]|\n"
"%Taggy%: [118]|[97]|[108]|\n"
"$Request$: [73]|[115]|[105]|[32]|[75]|\n"
"This shouldnt be valid%Taggy%: [118]|[97]|[108]|\n"
"$tAGged$: [97][97][97]|\n"
"$Request$: [73]|[115]|[105]|true\n")
subst = "$2 $3 $4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.