package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([$%])[A-Z][a-z]{2,}(?1): \[(?<fisrst>\d+)\]\|\[(?<second>\d+)\]\|\[(?<third>\d+)\]\|$`)
var str = `$Request$: [73]|[115]|[105]|
%Taggy$: [73]|[73]|[73]|
%Taggy%: [118]|[97]|[108]|
$Request$: [73]|[115]|[105]|[32]|[75]|
This shouldnt be valid%Taggy%: [118]|[97]|[108]|
$tAGged$: [97][97][97]|
$Request$: [73]|[115]|[105]|true
`
var substitution = "$2 $3 $4"
fmt.Println(re.ReplaceAllString(str, substitution))
}