#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(a)|(b)).*?(?(1)(?:(a)|(b))|(?(2)(?:(a)|(b)))).*?(?(3)b.*?b|(?(6)a.*?a|(?(4)(?:(a)|b).*?(?(7)b|a)|(?(5)(?:(a)|b).*?(?(8)b|a)))))$"
Local $sString = "Valid Cases:" & @CRLF & _
"a1a3bb" & @CRLF & _
"b2b6aa" & @CRLF & _
"a1b4a7b" & @CRLF & _
"a1b4ba" & @CRLF & _
"b2a5a8b" & @CRLF & _
"b2a5ba" & @CRLF & _
"" & @CRLF & _
"abab" & @CRLF & _
"baba" & @CRLF & _
"abba" & @CRLF & _
"baab" & @CRLF & _
"aabb" & @CRLF & _
"bbaa" & @CRLF & _
"" & @CRLF & _
"Test Invalid Cases:" & @CRLF & _
"aba" & @CRLF & _
"bab" & @CRLF & _
"aa" & @CRLF & _
"bb"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")