import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(a)|(b)).*?(?(1)(?:(a)|(b))|(?(2)(?:(a)|(b)))).*?(?(3)b.*?b|(?(6)a.*?a|(?(4)(?:(a)|b).*?(?(7)b|a)|(?(5)(?:(a)|b).*?(?(8)b|a)))))$";
final String string = "Valid Cases:\n"
+ "a1a3bb\n"
+ "b2b6aa\n"
+ "a1b4a7b\n"
+ "a1b4ba\n"
+ "b2a5a8b\n"
+ "b2a5ba\n\n"
+ "abab\n"
+ "baba\n"
+ "abba\n"
+ "baab\n"
+ "aabb\n"
+ "bbaa\n\n"
+ "Test Invalid Cases:\n"
+ "aba\n"
+ "bab\n"
+ "aa\n"
+ "bb";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}