use strict;
my $str = 'Valid Cases:
a1a3bb
b2b6aa
a1b4a7b
a1b4ba
b2a5a8b
b2a5ba
abab
baba
abba
baab
aabb
bbaa
Test Invalid Cases:
aba
bab
aa
bb';
my $regex = qr/(?:(a)|(b)).*?(?(1)(?:(a)|(b))|(?(2)(?:(a)|(b)))).*?(?(3)b.*?b|(?(6)a.*?a|(?(4)(?:(a)|b).*?(?(7)b|a)|(?(5)(?:(a)|b).*?(?(8)b|a)))))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}