re = /(?:(a)|(b)).*?(?(1)(?:(a)|(b))|(?(2)(?:(a)|(b)))).*?(?(3)b.*?b|(?(6)a.*?a|(?(4)(?:(a)|b).*?(?(7)b|a)|(?(5)(?:(a)|b).*?(?(8)b|a)))))$/m
str = 'Valid Cases:
a1a3bb
b2b6aa
a1b4a7b
a1b4ba
b2a5a8b
b2a5ba
abab
baba
abba
baab
aabb
bbaa
Test Invalid Cases:
aba
bab
aa
bb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end