using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(a)|(b)).*?(?(1)(?:(a)|(b))|(?(2)(?:(a)|(b)))).*?(?(3)b.*?b|(?(6)a.*?a|(?(4)(?:(a)|b).*?(?(7)b|a)|(?(5)(?:(a)|b).*?(?(8)b|a)))))$";
string input = @"Valid Cases:
a1a3bb
b2b6aa
a1b4a7b
a1b4ba
b2a5a8b
b2a5ba
abab
baba
abba
baab
aabb
bbaa
Test Invalid Cases:
aba
bab
aa
bb";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}