const regex = new RegExp('(?:(a)|(b)).*?(?(1)(?:(a)|(b))|(?(2)(?:(a)|(b)))).*?(?(3)b.*?b|(?(6)a.*?a|(?(4)(?:(a)|b).*?(?(7)b|a)|(?(5)(?:(a)|b).*?(?(8)b|a)))))$', 'gm')
const str = `Valid Cases:
a1a3bb
b2b6aa
a1b4a7b
a1b4ba
b2a5a8b
b2a5ba
abab
baba
abba
baab
aabb
bbaa
Test Invalid Cases:
aba
bab
aa
bb`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}