import re
regex = re.compile(r"(?:(a)|(b)).*?(?(1)(?:(a)|(b))|(?(2)(?:(a)|(b)))).*?(?(3)b.*?b|(?(6)a.*?a|(?(4)(?:(a)|b).*?(?(7)b|a)|(?(5)(?:(a)|b).*?(?(8)b|a)))))$", flags=re.MULTILINE)
test_str = ("Valid Cases:\n"
"a1a3bb\n"
"b2b6aa\n"
"a1b4a7b\n"
"a1b4ba\n"
"b2a5a8b\n"
"b2a5ba\n\n"
"abab\n"
"baba\n"
"abba\n"
"baab\n"
"aabb\n"
"bbaa\n\n"
"Test Invalid Cases:\n"
"aba\n"
"bab\n"
"aa\n"
"bb")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")