#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "asignarValores\('([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)'\)"
Local $sString = "asignarValores('agregarDeudaCarroCompra', '12345678', '01', 'INS', '2009', '2', '0')" & @CRLF & _
"" & @CRLF & _
"asignarValores('uno', 'dos', 'tres', 'cuatro', 'cinco', 'seis', 'siete')" & @CRLF & _
"" & @CRLF & _
"asignarValores('u\'n\'o', 'd\\\\\'os', 't\n\'\tres', 'cuatro\\\\\\\\\\\'', 'ci\'nco', 'seis\\', 'siete')"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")