// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"asignarValores\('([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)'\)").unwrap();
let string = "asignarValores('agregarDeudaCarroCompra', '12345678', '01', 'INS', '2009', '2', '0')
asignarValores('uno', 'dos', 'tres', 'cuatro', 'cinco', 'seis', 'siete')
asignarValores('u\\'n\\'o', 'd\\\\\\\\\\'os', 't\\n\\'\\tres', 'cuatro\\\\\\\\\\\\\\\\\\\\\\'', 'ci\\'nco', 'seis\\\\', 'siete')";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}