import Foundation
let pattern = #"asignarValores\('([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)'\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
asignarValores('agregarDeudaCarroCompra', '12345678', '01', 'INS', '2009', '2', '0')
asignarValores('uno', 'dos', 'tres', 'cuatro', 'cinco', 'seis', 'siete')
asignarValores('u\'n\'o', 'd\\\\\'os', 't\n\'\tres', 'cuatro\\\\\\\\\\\'', 'ci\'nco', 'seis\\', 'siete')
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)