re = /asignarValores\('([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)'\)/
str = 'asignarValores(\'agregarDeudaCarroCompra\', \'12345678\', \'01\', \'INS\', \'2009\', \'2\', \'0\')
asignarValores(\'uno\', \'dos\', \'tres\', \'cuatro\', \'cinco\', \'seis\', \'siete\')
asignarValores(\'u\\\'n\\\'o\', \'d\\\\\\\\\\\'os\', \'t\\n\\\'\\tres\', \'cuatro\\\\\\\\\\\\\\\\\\\\\\\'\', \'ci\\\'nco\', \'seis\\\\\', \'siete\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end