import re
regex = re.compile(r"asignarValores\('([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)'\)")
test_str = ("asignarValores('agregarDeudaCarroCompra', '12345678', '01', 'INS', '2009', '2', '0')\n\n"
"asignarValores('uno', 'dos', 'tres', 'cuatro', 'cinco', 'seis', 'siete')\n\n"
"asignarValores('u\\'n\\'o', 'd\\\\\\\\\\'os', 't\\n\\'\\tres', 'cuatro\\\\\\\\\\\\\\\\\\\\\\'', 'ci\\'nco', 'seis\\\\', 'siete')")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")