const regex = /asignarValores\('([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)'\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('asignarValores\\(\'([^\'\\\\]*(?:\\\\.[^\'\\\\]*)*)\', \'([^\'\\\\]*(?:\\\\.[^\'\\\\]*)*)\', \'([^\'\\\\]*(?:\\\\.[^\'\\\\]*)*)\', \'([^\'\\\\]*(?:\\\\.[^\'\\\\]*)*)\', \'([^\'\\\\]*(?:\\\\.[^\'\\\\]*)*)\', \'([^\'\\\\]*(?:\\\\.[^\'\\\\]*)*)\', \'([^\'\\\\]*(?:\\\\.[^\'\\\\]*)*)\'\\)', 'g')
const str = `asignarValores('agregarDeudaCarroCompra', '12345678', '01', 'INS', '2009', '2', '0')
asignarValores('uno', 'dos', 'tres', 'cuatro', 'cinco', 'seis', 'siete')
asignarValores('u\\'n\\'o', 'd\\\\\\\\\\'os', 't\\n\\'\\tres', 'cuatro\\\\\\\\\\\\\\\\\\\\\\'', 'ci\\'nco', 'seis\\\\', 'siete')`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}