package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`asignarValores\('([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)', '([^'\\]*(?:\\.[^'\\]*)*)'\)`)
var str = `asignarValores('agregarDeudaCarroCompra', '12345678', '01', 'INS', '2009', '2', '0')
asignarValores('uno', 'dos', 'tres', 'cuatro', 'cinco', 'seis', 'siete')
asignarValores('u\'n\'o', 'd\\\\\'os', 't\n\'\tres', 'cuatro\\\\\\\\\\\'', 'ci\'nco', 'seis\\', 'siete')`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}