using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^wp-content\/uploads\/2019\/+\d[(9|10|11|12)]+\/+\d+\/dsc+.+jpg$";
string input = @"wp-content/uploads/2019/04/04150417/dsc01813.jpg
wp-content/uploads/2019/04/04150414/dsc01814.jpg
wp-content/uploads/2019/04/04150410/dsc01815.jpg
wp-content/uploads/2019/09/04150410/dsc01815.jpg
wp-content/uploads/2019/10/04150410/dsc01815.jpg
wp-content/uploads/2019/11/04150410/dsc01815.jpg
wp-content/uploads/2019/12/04150410/dsc01815.jpg
wp-content/uploads/2019/08/04150410/dsc01815.jpg
wp-content/uploads/2019/01/04150410/dsc01815.jpg
wp-content/uploads/2019/02/04150410/dsc01815.jpg
wp-content/uploads/2019/04/04150417/dsc01813.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}