# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^wp-content\/uploads\/2019\/+\d[(9|10|11|12)]+\/+\d+\/dsc+.+jpg$"
test_str = ("wp-content/uploads/2019/04/04150417/dsc01813.jpg\n"
"wp-content/uploads/2019/04/04150414/dsc01814.jpg\n"
"wp-content/uploads/2019/04/04150410/dsc01815.jpg\n"
"wp-content/uploads/2019/09/04150410/dsc01815.jpg\n"
"wp-content/uploads/2019/10/04150410/dsc01815.jpg\n"
"wp-content/uploads/2019/11/04150410/dsc01815.jpg\n"
"wp-content/uploads/2019/12/04150410/dsc01815.jpg\n"
"wp-content/uploads/2019/08/04150410/dsc01815.jpg\n"
"wp-content/uploads/2019/01/04150410/dsc01815.jpg\n"
"wp-content/uploads/2019/02/04150410/dsc01815.jpg\n"
"wp-content/uploads/2019/04/04150417/dsc01813.jpg")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.