const regex = /^wp-content\/uploads\/2019\/+\d[(9|10|11|12)]+\/+\d+\/dsc+.+jpg$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^wp-content\\\/uploads\\\/2019\\\/+\\d[(9|10|11|12)]+\\\/+\\d+\\\/dsc+.+jpg$', 'gm')
const str = `wp-content/uploads/2019/04/04150417/dsc01813.jpg
wp-content/uploads/2019/04/04150414/dsc01814.jpg
wp-content/uploads/2019/04/04150410/dsc01815.jpg
wp-content/uploads/2019/09/04150410/dsc01815.jpg
wp-content/uploads/2019/10/04150410/dsc01815.jpg
wp-content/uploads/2019/11/04150410/dsc01815.jpg
wp-content/uploads/2019/12/04150410/dsc01815.jpg
wp-content/uploads/2019/08/04150410/dsc01815.jpg
wp-content/uploads/2019/01/04150410/dsc01815.jpg
wp-content/uploads/2019/02/04150410/dsc01815.jpg
wp-content/uploads/2019/04/04150417/dsc01813.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}