$re = '/^wp-content\/uploads\/2019\/+\d[(9|10|11|12)]+\/+\d+\/dsc+.+jpg$/m';
$str = 'wp-content/uploads/2019/04/04150417/dsc01813.jpg
wp-content/uploads/2019/04/04150414/dsc01814.jpg
wp-content/uploads/2019/04/04150410/dsc01815.jpg
wp-content/uploads/2019/09/04150410/dsc01815.jpg
wp-content/uploads/2019/10/04150410/dsc01815.jpg
wp-content/uploads/2019/11/04150410/dsc01815.jpg
wp-content/uploads/2019/12/04150410/dsc01815.jpg
wp-content/uploads/2019/08/04150410/dsc01815.jpg
wp-content/uploads/2019/01/04150410/dsc01815.jpg
wp-content/uploads/2019/02/04150410/dsc01815.jpg
wp-content/uploads/2019/04/04150417/dsc01813.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);