// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^wp-content\/uploads\/2019\/+\d[(9|10|11|12)]+\/+\d+\/dsc+.+jpg$").unwrap();
let string = "wp-content/uploads/2019/04/04150417/dsc01813.jpg
wp-content/uploads/2019/04/04150414/dsc01814.jpg
wp-content/uploads/2019/04/04150410/dsc01815.jpg
wp-content/uploads/2019/09/04150410/dsc01815.jpg
wp-content/uploads/2019/10/04150410/dsc01815.jpg
wp-content/uploads/2019/11/04150410/dsc01815.jpg
wp-content/uploads/2019/12/04150410/dsc01815.jpg
wp-content/uploads/2019/08/04150410/dsc01815.jpg
wp-content/uploads/2019/01/04150410/dsc01815.jpg
wp-content/uploads/2019/02/04150410/dsc01815.jpg
wp-content/uploads/2019/04/04150417/dsc01813.jpg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}