re = /^wp-content\/uploads\/2019\/+\d[(9|10|11|12)]+\/+\d+\/dsc+.+jpg$/m
str = 'wp-content/uploads/2019/04/04150417/dsc01813.jpg
wp-content/uploads/2019/04/04150414/dsc01814.jpg
wp-content/uploads/2019/04/04150410/dsc01815.jpg
wp-content/uploads/2019/09/04150410/dsc01815.jpg
wp-content/uploads/2019/10/04150410/dsc01815.jpg
wp-content/uploads/2019/11/04150410/dsc01815.jpg
wp-content/uploads/2019/12/04150410/dsc01815.jpg
wp-content/uploads/2019/08/04150410/dsc01815.jpg
wp-content/uploads/2019/01/04150410/dsc01815.jpg
wp-content/uploads/2019/02/04150410/dsc01815.jpg
wp-content/uploads/2019/04/04150417/dsc01813.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end