import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^wp-content\\/uploads\\/2019\\/+\\d[(9|10|11|12)]+\\/+\\d+\\/dsc+.+jpg$";
final String string = "wp-content/uploads/2019/04/04150417/dsc01813.jpg\n"
+ "wp-content/uploads/2019/04/04150414/dsc01814.jpg\n"
+ "wp-content/uploads/2019/04/04150410/dsc01815.jpg\n"
+ "wp-content/uploads/2019/09/04150410/dsc01815.jpg\n"
+ "wp-content/uploads/2019/10/04150410/dsc01815.jpg\n"
+ "wp-content/uploads/2019/11/04150410/dsc01815.jpg\n"
+ "wp-content/uploads/2019/12/04150410/dsc01815.jpg\n"
+ "wp-content/uploads/2019/08/04150410/dsc01815.jpg\n"
+ "wp-content/uploads/2019/01/04150410/dsc01815.jpg\n"
+ "wp-content/uploads/2019/02/04150410/dsc01815.jpg\n"
+ "wp-content/uploads/2019/04/04150417/dsc01813.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}