import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S+) (\\S+) (\\S+) (\\S+) ((?:[[:alpha:]]+)(?:\\s+[[:alpha:]]+)*) (\\S+) (\\S+) ((?:[[:alpha:]]+)(?:\\s+[[:alpha:]]+)*) (\\S+) (\\S+) (\\S+) (\\S+)$";
final String string = "05/02/2018 L0007761 1 13640 Trust Printshop 8394BLK05 8394 BLACK L 104.00 16.77 83.88\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}