re = /^(\S+) (\S+) (\S+) (\S+) ((?:[[:alpha:]]+)(?:\s+[[:alpha:]]+)*) (\S+) (\S+) ((?:[[:alpha:]]+)(?:\s+[[:alpha:]]+)*) (\S+) (\S+) (\S+) (\S+)$/m
str = '05/02/2018 L0007761 1 13640 Trust Printshop 8394BLK05 8394 BLACK L 104.00 16.77 83.88
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result