# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\S+) (\S+) (\S+) (\S+) ((?:[[:alpha:]]+)(?:\s+[[:alpha:]]+)*) (\S+) (\S+) ((?:[[:alpha:]]+)(?:\s+[[:alpha:]]+)*) (\S+) (\S+) (\S+) (\S+)$"
test_str = ("05/02/2018 L0007761 1 13640 Trust Printshop 8394BLK05 8394 BLACK L 104.00 16.77 83.88\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.