# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=<)(?:(?=.*?<(?!.*?\1)(.*>(?!.*\2).*))(?=.*?>(?!.*?\2)(.*)).)+?.*?(?=\1)[^<]*(?=\2$)//gms;t' <<< "Hey! < <Look,> <ma!> < <no> r<e<c<u<r>s>i>o>n!! > > Woooo
< Matches <can <even
span > multiple >
lines! > yeah buddy!!
<<<<<<<<><<<<<<><<<<<< NO LIMITS!!! >>>>>><>>>>>><>>>>>>>>>>>>>"