#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)(?=<)(?:(?=.*?<(?!.*?\1)(.*>(?!.*\2).*))(?=.*?>(?!.*?\2)(.*)).)+?.*?(?=\1)[^<]*(?=\2$)"
Local $sString = "Hey! < <Look,> <ma!> < <no> r<e<c<u<r>s>i>o>n!! > > Woooo" & @CRLF & _
"< Matches <can <even" & @CRLF & _
"span > multiple > " & @CRLF & _
"lines! > yeah buddy!!" & @CRLF & _
"<<<<<<<<><<<<<<><<<<<< NO LIMITS!!! >>>>>><>>>>>><>>>>>>>>>>>>>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)