import re
regex = re.compile(r"(?=<)(?:(?=.*?<(?!.*?\1)(.*>(?!.*\2).*))(?=.*?>(?!.*?\2)(.*)).)+?.*?(?=\1)[^<]*(?=\2$)", flags=re.MULTILINE | re.DOTALL)
test_str = ("Hey! < <Look,> <ma!> < <no> r<e<c<u<r>s>i>o>n!! > > Woooo\n"
"< Matches <can <even\n"
"span > multiple > \n"
"lines! > yeah buddy!!\n"
"<<<<<<<<><<<<<<><<<<<< NO LIMITS!!! >>>>>><>>>>>><>>>>>>>>>>>>>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)