re = /(?=<)(?:(?=.*?<(?!.*?\1)(.*>(?!.*\2).*))(?=.*?>(?!.*?\2)(.*)).)+?.*?(?=\1)[^<]*(?=\2$)/m
str = 'Hey! < <Look,> <ma!> < <no> r<e<c<u<r>s>i>o>n!! > > Woooo
< Matches <can <even
span > multiple >
lines! > yeah buddy!!
<<<<<<<<><<<<<<><<<<<< NO LIMITS!!! >>>>>><>>>>>><>>>>>>>>>>>>>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result