const regex = new RegExp('(?=<)(?:(?=.*?<(?!.*?\\1)(.*>(?!.*\\2).*))(?=.*?>(?!.*?\\2)(.*)).)+?.*?(?=\\1)[^<]*(?=\\2$)', 'gms')
const str = `Hey! < <Look,> <ma!> < <no> r<e<c<u<r>s>i>o>n!! > > Woooo
< Matches <can <even
span > multiple >
lines! > yeah buddy!!
<<<<<<<<><<<<<<><<<<<< NO LIMITS!!! >>>>>><>>>>>><>>>>>>>>>>>>>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);