$re = '~(?=<)(?:(?=.*?<(?!.*?\1)(.*>(?!.*\2).*))(?=.*?>(?!.*?\2)(.*)).)+?.*?(?=\1)[^<]*(?=\2$)~ms';
$str = 'Hey! < <Look,> <ma!> < <no> r<e<c<u<r>s>i>o>n!! > > Woooo
< Matches <can <even
span > multiple >
lines! > yeah buddy!!
<<<<<<<<><<<<<<><<<<<< NO LIMITS!!! >>>>>><>>>>>><>>>>>>>>>>>>>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;