using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=<)(?:(?=.*?<(?!.*?\1)(.*>(?!.*\2).*))(?=.*?>(?!.*?\2)(.*)).)+?.*?(?=\1)[^<]*(?=\2$)";
string substitution = @"";
string input = @"Hey! < <Look,> <ma!> < <no> r<e<c<u<r>s>i>o>n!! > > Woooo
< Matches <can <even
span > multiple >
lines! > yeah buddy!!
<<<<<<<<><<<<<<><<<<<< NO LIMITS!!! >>>>>><>>>>>><>>>>>>>>>>>>>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}