#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(ABCDE\_\S*\>|ABCDE\_)"
Local $sString = "Как получить "ABCDE_1234>" если есть ">" " & @CRLF & _
"Как получить "ABCDE_12345>" если есть ">" " & @CRLF & _
"Проверяем на строке "ABCDE_ABCDE_>" =)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")