// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(ABCDE\_\S*\>|ABCDE\_)").unwrap();
let string = "Как получить \"ABCDE_1234>\" если есть \">\"
Как получить \"ABCDE_12345>\" если есть \">\"
Проверяем на строке \"ABCDE_ABCDE_>\" =)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}